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Course Objectives 
 

During the day you will learn how to… 
 

 Recognise the Asta Powerproject desktop 

 Edit and apply working time through calendars 

 Create a linked bar chart 

 Understand and analyse the Critical Path and Float 

 Manipulate the chart using constraints 

 Summarise the bar chart 

 Create a coded reporting system 

 Edit the display  

 Update progress on your project 

 Print your project 
 
 
 
 
 
 
Topics will be backed up by exercises 
 
This booklet is yours to take away 
 
Please feel free to add any notes you feel are relevant 
 
Please ask any questions 

 

This area is for you to put 
your notes in. You’ll find it 
on every page in the 

training manual. 

 = Note, something 
of interest 

 = Warning, to 
make you aware o 
something. 
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Getting started 

Basics 
Powerproject follows many of the rules for windows. 

 

 Left click will usually select an item. 

 Double click will activate it. 

 Right click gives you a menu to make changes. 

 Click and drag will move an item from one part of the screen to another or 
will select multiple items. 

 Shift button will allow you to select adjacent items. 

 Control button will select non-adjacent items. 
 

Starting a new project 
To start a new project in Asta Powerproject: 

 

 Select the File tab 

 Select New 
 

 
 

 Select a template on which to base your project e.g. Construction Template. 

 Enter the details on the new project: 

 Filename – The name of the document 

 Name – The print title 

 For – Who the project is for i.e. the client 

 By – Who the project is by i.e. your name or company 

 Start – The start date for the whole project  

 Optionally you can enter a User Name and Password 
 
Once these details have been entered, click Create. 
 

Opening an existing project 
To start a new project in Asta Powerproject: 

 

 Select the File tab 

 If your project has been opened recently, select Recent. Your recent projects 
are displayed to the right. 

 If your project has not been opened recently, Select 

 Then select the file you wish to open. 
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Saving a file 
As you work in your Asta Powerproject File you can save by: 
 

 Selecting the save button on the quick access tool bar 
 
 

 
 
 
 
 
 

 Or, by returning to the File tab and selecting Save. 
 

Saving a file under a new name 
If you want to save the project under a new file name: 
  

 Select the File tab 

 Select Save As  

 
Select where 
you wish to save 
the project 

 
 
Enter your new 
file name 

 
 
Choose a 
suitable file type 

 
 
 
 
 
 

Closing a project 
   To close the active Asta Powerproject File: 
 

 Close the project tabs using the X next to each  
 

 
 
 

 If you open a 
project from a previous 
version it will convert 
the file to the latest 
version. Previous 
versions will then no 
longer be able to open 
the file. 
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Or 

 

 Return to the File tab and select   
 

If the project has not been saved you will be prompted to do so. 
 

Exiting Asta Powerproject 
To exit Asta Powerproject: 
 

 Click on the X at the top right of the screen 
 

 
 
If you try to close an individual project, or the Powerproject software altogether, 
without saving, Powerproject will ensure you do not accidentally lose changes 
by prompting to ask if you want to save.  
 

 
 

Asta Powerproject screen areas 
This section covers the general layout of the Asta Powerproject working area. 
 
The Asta Powerproject screen is divided into a number of areas. This may vary 
for existing projects where the layout has been changed to suit the needs of the 
user. 

 

  
 

  Ribbon – Contains the commands for your project 

 Project View – Shows the structure of your project and shows the list of 
library items available. 

 Barchart – Information on your project in graphic form, your Gantt Chart 

 Date zone 

 Spreadsheet – Information on your project in tabular form 

 Properties View – Allows you to edit the properties of a selected object 

Ribbon 

Project 
View 

Barchart 
Spreadsheet 

Object Edit Toolbar 

Properties View 

Date zone 
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 Object Edit Toolbar – Used to edit tasks and/or links in the barchart 

The Ribbon 
The ribbon area in Asta Powerproject gives you access to all the features you 
will need when working on your project. It has 5 main tabs, each with a different 
set of commands and 1 tab to return to the backstage area of the project. 
 

 
 

 Home – Contains the most popular commands 

 View – Commands that will change the way your project and screen layout 
looks 

 Project – Project data commands 

 Allocation – Commands to allocate cost and resource information 

 Format – To change the Barchart and Date Zone formatting 
 

The Project View 
The project view shows the structure of your project and shows the list of library 
items available. 
 
The project view area can be hidden if screen space is at a premium by: 
 

 Selecting the Format tab and clicking the  command 
Or 
 

 Selecting the same command on the bottom toolbar 
 

  
 

 
You can resize the area to make the content clearly visible by: 

 

 Place the cursor over the left edge of the table area. The cursor will become a 
double sided arrow. Drag this to the right of  the screen 
 

Properties View 
The properties view allows you to add and edit data to selected object in your 
project. It can be set to show permanently or set to auto hide.  
 
To open and close the Properties View: 
 

 Select  the Properties View command on the bottom toolbar 
 

  
 

To set the Properties View to auto hide: 
 

 Click the pin icon on the Properties View title bar so the pin 
faces to the left of the screen. 
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The Default 
Calendar icon 

 The Properties View will reduce to a tab at 
the bottom right of the screen when 
unselected.  

 
 

Creating a project 

A project is a series of tasks which must be completed to achieve a set of 
objectives. The Spreadsheet displays the task information and the GANTT chart 
(Bar Chart) shows the tasks in their date position and duration 

 

 
 

 
A Task is a unit of work with a duration.  Tasks can be created on the 
Spreadsheet or drawn onto the GANTT chart and they can be linked to show 
relationships between them to create the critical path.  You can create more 
than one task on the same bar to show repetitive or intermittent working.  Task 
names can be used to describe the task, and do not need to be unique. 

Calendars 

Calendars define the working and working time within a project. The Calendar 
consists of a planned pattern of work to which exceptions can be added. An 
exception is any day which does not conform to the planned pattern of work, 
e.g. holidays or overtime.  
 
The Construction and Housing templates both contain Calendars which cover 
the most common working patterns. Customised templates may have Calendars 
tailored to your individual requirements.  
 
To display a list of available Calendars: 

 

 In the Project View, open the calendars folder using the + symbol 
 

 
 
 
 
 
 
 
 
 
 
 
 

 
 

 Sub folders are opened in the same way. 
 

One calendar in the list will be set as the default, meaning that any new task you 
create will follow that calendars work pattern.  
 
You will need to select which calendar is the closest to your won working 
patterns and set that as the default. 
 

Click on the „+‟ 
symbol to 
display the 
contents of a 
folder 



  7 

 

 Asta Development plc Sep-12 

To select which calendar you wish to use as the default: 
 

 Right click on the calendar you wish to set as the default 

 Select Task Default from the list  
 

 
 

 The tick will move to the new default calendar 
 
Once the default calendar has been selected, you can then edit the calendars 
properties to the specic working patterns of this project. 
 
To edit the calendar: 
 

 Right click on the calendar you wish to edit 

 Select Properties 
 

Calendar screen overview  
Each day in the Calendar has a working pattern assigned to it. An exception is 
any day which does not follow that working pattern.   
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Each day has a period of working and non working time assigned. To view 
these times 
 

Legend to colour codes 
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 Double click on the day you wish to view. The day will open in a separate pop 
up, showing the working and non working time during that day. N.B All Asta 
supplied calendars have the same 8 hour per day pattern. 
 

 
 

Adding exceptions 
If a date in the calendar does not match your working pattern you will be able to 
add or delete exceptions to the dates to change them. To add an exception to 
any dates: 

 

 Left click on the date you wish to select. If you wish to select more than one 
date, you will need to hold the CTRL key and click on each date. 

 Click the Add Exception button. 

 Choose which Exception type you wish to add. 

 Choose the period of time you wish the exception to last for in the Exception 
period section. 

 Click Add 
 

When adding an exception, it is important to set the correct time periods.  
 

 Specific start and end times allows you to set the start and finish of the time 
to the nearest 30mins.  

 From work pattern periods matches the morning and afternoon to those 
already set for the calendar. (This option will produce the best results) 

 24 hour exception will add the selected exception for the whole 25 hours of 
the day. 

 
 
 
 
 

 
 
 
 

 Holiday 
exceptions are 
allocated to the whole 
24hr period. Simply 
tick the box for All day 
exception 

 
1. Select the type of exception 
 
2. Pick a period of time for that 
exception: 
 

a. Specific  times 
b. From work pattern 

periods 
c. 24 Hour Exception. 
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Deleting exceptions 
Removing an exception form a date will return those dates back to the standard 
work pattern. To  
 

 Select the dates with the exceptions you wish to remove. 

 Click Delete Exceptions 

 A pop up will appear asking if you are sure you wish to delete the exceptions. 
If you are, select Yes, if not select No. 
 

Entering your task data 
Once the calendar has been established you will be able to start entering your 
task data, entering the correct durations for each task. 

 

Entering bar & task names 
To create the task titles that will make up the project: 

 

 Move the mouse pointer over an empty cell in the 
Name column and left click 

 Type the name „Set up Site‟ and press ENTER. 

 Type in the activity list, as shown. 
 
 
 

Creating tasks 
A task can be created by either typing the duration into the column on the 
Spreadsheet, or by using the cursor to draw onto the Bar Chart. Once created, 
any aspect of the task can be edited using either the Spreadsheet or using the 
mouse on the task bar. 
 
To create tasks in the Spreadsheet: 

 

 Click in the duration column of the first task of the table. 

 Type the duration you wish into the column. 
 

You can use any duration unit by adding the appropriate letter after the number, 
i.e. d for days and w for weeks.   

 

 Press ENTER. A task is displayed on the Bar Chart. 
  

To create tasks on the Bar Chart: 
 

 Place the mouse cursor in the Bar Chart on the line for the task, the cursor 
will now be a cross 

 Left click and drag the mouse to the right. 
 
A pop up box displays the duration of the task.  
 

 Release the mouse button when the task is 5d. 
 

 
 

 The task will remain selected (Highlighted in black) 

 The task is 
changed in time units as 
set by the ‘Snapping 
Time Unit’  
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 Click away from the task to deselect it & it is displayed green again. 
 

Moving and editing tasks 
Tasks can be moved and edited using either the mouse or the Object Edit 
Toolbar. 
 
To edit your tasks on the Bar Chart: 
 

 Point your cursor at the task you wish to edit. 

 Your cursor will change shape: 
 

 Select  / Move task 
Place mouse cursor in the centre of a 
task. Left click & drag 
While this cursor shape is showing an 
item can be selected or moved.  

 

 
 

 

Adjust start date of task 
Place mouse cursor at start of a task. 
Left click & drag 
While this cursor shape is showing 
the start date of a task can be moved 
without affecting the end date. 

 
 
 

 

Adjust end date of task 
Place mouse cursor at the end of a 
task. Left click & drag. 
While this cursor shape is showing 
the end date of a task can be moved 
without affecting the start date.  

 
Using the Object Edit Toolbar: 
 

 Select a task on the Bar Chart using the                  cursor as shown above. 

 The Object Edit Toolbar is now displayed at the foot of the screen. 
 
 
 
 
 
 
 
 
 

Moving bars vertically 
When you have listed out your task you are still able to change the order of 
those tasks at anytime  
 
To move before start on site to the top of your project: 

 

 Left click and hold just to the left hand side on the line number for the task 
you want to move. You should see the                  cursor 
 

  
 

 Click and drag the bar to the new line above. 

To move date 
position of 
selected tasks - 
earlier/later 

To change 
start date of 
selected 
tasks 

To change 
end date of 
selected 
tasks 

 To delete a 
task, first select it, then 
press delete on the 
keyboard 
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Inserting bars 
You can insert new lines into your project to put new tasks on or just to spate 
exiting tasks for formatting purposes. 
 

 Left click on the line number below where you want to insert your new line. 

 Right click and select Insert Bar or press insert on your keyboard 

 A blank bar will be inserted above the currently selected bar. 
 

Milestones 
Milestones are used to display key dates or events in our project and have zero 
duration. 
 
To create a Milestone: 

 

 Name the task in the normal way. Enter 0 (zero) in the duration column. The 
0 will not display as the default is to not show zeros 

 

 
 
Milestones can be either a Start or Finish milestone. Start Milestones will show 
at the start of a working day, whereas Finish milestones will show at the end of 
the working day. E.g. if a task is completed on Friday afternoon, a Start 
Milestone will appear on Monday morning. A Finish Milestone will appear at 
the end of Friday afternoon. By default you will create Start milestone. (This is 
set in the bar chart default settings) 
 
 To change a Milestone into a Finish Milestone:  response 

 

 Right click on the Milestone. Select Make into – Finish Milestone. 
 

Task-per-line mode 
In Asta Powerproject, It is possible to display more than one task on a bar. 
This is useful if you have several tasks of the same type or you have a process 
made up of a number of single tasks. Asta Powerproject can separate tasks 
that exist on the same line by dropping them down onto separate lines. This is 
achievable by using Task-per-line mode.  
 
To create multiple tasks on the same line, either: 
 

 Draw more than one task onto the same line in the Bar chart. 
 

 
 

Or if you have already created the tasks on separate lines: 

 To specify a 
Finish-to -Start 
relationship between 
tasks on the same line 
no link is required, 
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 Select the line numbers of the tasks you wish to place on one line 

 On the Home tab, click the Roll up tasks   command 
 

 

The process can be revered using the Unroll task   command. 

Linking tasks 
Once you have entered in your tasks you will need to consider the order that 
you wish to approach those tasks. It is possible at this point to move the tasks 
into order by selecting the start and finish dates that you wish to use. 
 
However, in order for the software to understand the order that you wish to work 
through your project, you will need to link your tasks to indicate how they relate 
to each other. 
 

Link types 
Links can be drawn starting and ending anywhere along the length of a task 
and you can link tasks in many different ways.  The type of link used depends 
on the nature of the relationship between tasks.  
 
There are 4 types of link: 

 

 
In all cases, the direction of the arrow controls where the next task appears (A 
controls where B appears). 
 
Links are drawn between tasks using following cursor shapes:   

 
 

 
 

 
End link Cursor 
 
This cursor shape indicates that you are 
linking from / to the end of a task 

 

 
 

 
Start link Cursor 
 
This cursor shape indicates that you are 
linking from / to the start of a task 

 

 
 

 
Mid-link Cursor 
 
This cursor shape enables you to link from / to 
any midpoint along the length of a task.  A pop 
up box will indicate your exact position during 
the task. E.g. 3 days into a 10 day task 

To draw a finish to Start link between 2 tasks: 

 

 

 

 To select a 
link point to it & left 
click.  
 
Links are green when 

Start-to-Start Finish-to-Finish Finish-to-Start Start-to-Finish 

A 

B 

A A A 

B B B 
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 Place the mouse at the end and at the top or bottom corner of the first 
(predecessor) task to display the end link cursor. 

 Left click & drag to draw the link to the start of the corresponding (successor) 
task.  

 Release the mouse when the start link cursor is displayed. 
 

A link is made between the 2 tasks. The link arrow is green. This means that the 
link is selected.  

 

 Click elsewhere on the bar chart to deselect the link.  

 
 

This now tells Asta Powerproject that task B cannot start before task A is 
finished.  

 
Sometimes it is necessary to show that tasks will happen simultaneously.  
 
To show this a link is drawn starting or ending somewhere along the length of a 
task known as a mid-link. 

 

 
 

To draw a mid-link: 
 

 Place the cursor at the start of the predecessor task. Without pressing move 
the cursor to the right so that the mid-link cursor is displayed. 

 A pop up box will indicate where during the task you are linking from. 

 Left click at the desired position and drag to move the pointer to the desired 
position on the successor task.  

 Release the mouse when the corresponding link cursor is displayed. 
 

Drawing links with lead/lag time 
There may be times when you need to insert a period of waiting or delay into 
your project, e.g. waiting for paint to dry or concrete to cure.  

 

 
 

 Move the cursor to the bottom right hand corner of the predecessor task so 
that the end link icon appears, left click and keep the mouse button held 
down.  

 Press and hold the Shift button on the keyboard and with the mouse button 
still held down drag the cursor horizontally.  A pop up box will appear 
displaying the lead/lag duration. 

Task A 

Task B 

Task A 

Task B 

Task A 

Task B 

 If the pop up box 
does not appear when 
the mid-link is displayed 
go to the Tools tab, 
select Options, then find 
the General tab and put 
a tick in the box to show 

lead/lag pop up. 



14  

 

 Asta Development plc Sep-12 

 
 

 

 
 
 
 
 

 Once you have reached the desired duration release Shift but keep hold of 
your mouse button and drag it over to where you want to end the link and let 
go. 

 

 
 
You can also create a lag link by: 
 

 Drawing a standard Finish to start Link 

 Editing the link properties in the object edit toolbar 
 

Moving/Editing Links 
If you have drawn a link incorrectly, you can simply „drag‟ the link to the correct 
position, rather than deleting & re drawing the link.  

 

 Select the link (it will show as green) 

 Hover the cursor over the end of the link you wish the move until a „cross‟ 
cursor becomes visible.  

 The link can now be dragged to the correct position 

 
 

 
 
 

Multiple links in a sequence can be highlighted by selecting the first link in the 
sequence, holding the SHIFT key and selecting the last link in the sequence. 

 

Block linking 
 
If you have more than 2 tasks to link together e.g. a whole section of work, the 
link tasks toolbar button can be used. 

 

The link should have been to 
the start of task 3 

When the link is selected 
the Drag/Move Cursor 
can be displayed 

Pull the link to the correct 
position on the task  

Hold SHIFT whilst 
drawing the link to 
set the lag duration 
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 Select the tasks that you want to link. 
 

To link tasks that are next to each other on your chart click on the line number of 
the first bar. Left click & drag downwards to select adjacent bars.  
 
To link tasks that are not next to each other on the chart hold the ctrl button on 
keyboard while clicking on line number the task you want to link. 

 

 Click on the link tasks toolbar button. 
 

 
Finish to Start links are placed between each of the tasks. 

 

Linking tasks without drawing on the Bar Chart 
As well as drawing links directly onto the Bar Chart using the mouse, you can 
also link tasks by selecting one or more tasks in the Bar Chart and specifying 
the task you want to link to by name.  Creating links in this way is an easy way 
to link tasks which are not close to each other in the Bar Chart. 

 

 Right click on a task or tasks on the Bar Chart.  

 Select Linking, Link From/To    
 
 
 
 

 
 

 
 
 
The Link From / To dialog is displayed: 
 
 
 
 
 

 Indicate whether you are linking from or to the 
selected task(s). 

 Identify the task you are linking to. 

 Select the type of link. 

 Press Link and Close. 
 

Navigate the Logic and Edit the links 
You can use the links tab of the Task properties dialog box to navigate through 
the logic of your project.  

 
  

 
 

 The Link From / 
To dialog can also 
appear when you draw 
a link into a blank area 
of the Bar Chart, i.e. do 
not complete link to a 
successor task. Go to 
Tools tab, select 
Options, then find the 
Edit tab and select the 
Display Link From/To 
radio button. 
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 When you double click on a link, the task at the other end of the link 
(predecessor or successor) is centred in the Bar Chart window. This new task 
is now the subject of the task properties dialog. 
 

To edit the links:  
 

 Select your Incoming or Outgoing link shown in the box above 

 Choose whether to Add, Remove, Change or go to the Properties of the 
chosen link, via one of the buttons displayed 

Reschedule 

When you have linked your tasks you can Reschedule the project. The 
reschedule performs a series of actions: 

 

 Places the start of the first task at the beginning of the project. 

 Calculates the optimum start and end dates of all tasks according to the 
logical links applied. 

 Calculates whether a task has any float attached. 

 Shows whether a task is Critical (Critical Path Analysis). 

 Identifies any constraints which have been exceeded. 

 Calculates the earliest project end date. 
 

To Reschedule the project: 
 

 On the Home tab and click the Reschedule command  
 

 
 

 

 The critical path of the project is shown outlined in red. 
 

In Version 12 of Asta Powerproject you are able to specify how the critical path 
shows on tasks which are partially critical. 
 
To show only Partial Criticality: 
 

 On the Format tab, select Format Bar Chart. 

 In the Schedule Tab tick Part Critical Shading 

Reschedule Report 

Once you reschedule your project, a box may appear asking if you would like to 
view the reschedule report.  
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The reschedule report is a comprehensive breakdown of what impact the 
reschedule has had on your project. If you do not wish to see the report then 
select „Off‟.  
 

  
 
To switch the report back on, you will need to: 
 

 Open the File  Tab 

 Select Options 

 In the pop up, select the Reschedule tab and select Settings in the 
Reschedule Report area. 
      

 

 Tick Display report in browser 
 

Changing the project start date 
The start date of the project can be changed at any time. This will control when 
the first task in your project will reschedule to. 
 
To change the Start date: 
 

 In the File tab, select Advanced Properties 

 Change the Imposed Start to the new project start date. 

 Click Close. 

 Reschedule the project to see the new start date take effect 

Constraints 

Once the tasks have been linked and rescheduled, your project will be laid on 
the most logical order. What we have yet to take into consideration are any fixed 
dates that will need to be adhered to, such as a specific start on site date or a 
contract completion date. 
 
To show fixed dates in your project, and to show the impact they have on the 
rest of the tasks in your project you will need to use Constraints on those tasks. 
 

Adding a constraint 
To add a constraint to a task: 
 

 Select the task you wish to constrain 
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 On the Home tab click on the drop down arrow 

under the constraint  command 

 Select the constrain you wish to impose on the task 
 

 
 
 

 Click and drag the constraint to the required 
position 

 

 
 

 
Types of Constraint 

 
 

 

Start on or after. 
A soft constraint which will not allow the task to start before the 
constraint date, however to could move to a later date.  

 

Start on 
A hard constraint which will fix the start of the task to a constraint 
date 

 

Finish on or before 
A soft constraint that will not allow the task to end after the 
constraint date, however it could finish earlier.  

 

Deadline 
A soft constraint which works as a warning but will allow the 
project to move beyond the target deadline. 

 

Finish on 
A hard constraint that will fix the end date of the task to the 
constraint date 

 

Schedule between 
A soft constraint that will allow either the start or the end date to be 
constrained between 

 
Holding pin 
A Constraint which will move with the task if the task is manually 
moved.  

 

Reschedule results 
 
Rescheduling a project with constraints will affect the appearance of tasks & 
may result in some items showing Float. 

 

 

 

 

 

 

Critical Task - displayed in red. If a critical task is 

delayed, it will change the project end date. 

Total float – the period a task can be delayed or extended 
without delaying the end of the project - however this will 
affect other tasks (successor tasks) 

Free float – the period a task can be delayed or extended 
without affecting the end of the project - or any other 
tasks. 
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Structuring the project 
Project management is not only about defining tasks and setting up their 
dependencies, it is also about organising the different parts of a project into a 
coordinated whole. 
 
Asta Powerproject lets you organise your project using Summary Tasks to 
group related tasks together and this section explains how you can use 
summary bars to structure your project in a logical format. 
 

Creating summary tasks 
Summary tasks are useful for grouping related activities together in sequential 
order.  A summary task takes its position and duration from the position and 
duration of the tasks within the summary group. It provides „rolled up‟ 
information relating to all tasks within the summary and gives the user control 
over displaying each & every task in the project or displaying only the 
summarised information.  
 
To summarise tasks in the project: 

 

 Highlight the bars you wish to group together by clicking and dragging on the 
line numbers within the table. 

 On the Home tab click the Summarise command.  

 A summary bar appears on the Bar chart 
 

 
 

 Enter a name for the summary bar in the table e.g. Substructure 
 

You can now choose to hide the tasks that are part of the summary group from 
the chart so that only the summary bar & „rolled up‟ details are displayed. 
 

Opening and closing summary tasks: 

 On the Bar Chart, place the cursor over the summary task so that the sweet 
wrapper cursor is displayed                            and double-click.  

 The individual tasks are hidden from view. 
 

 
 

 Double click again to display the tasks. 
 

Adding & Removing tasks into Summary Groups 

 Select the bar(s) by clicking on the line number. 

 On the Home tab click on the indent button on the toolbar.   

 Bars are added to the summary that is above. 

 To remove tasks from a summary group, use the outdent button. 
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Removing Summary Tasks 

 Select all of the contents of the summary group. 

 Click the outdent button from the toolbar. 
 

If there are no contents in the summary group the summary task no longer 
exists.  
 

Summary bar level formatting 
The spreadsheet cell font and colour, as well as the background colour for that 
row on the bar chart, can now be set for a Summary/Expanded task in the 
Project View. The colouring is set for each level of the project, so more than one 
summary may have the same colour. 
 
To alter the appearance of the summary bar/Expanded task: 

 

 In the Project view right click on the Summary bar that you wish to colour 
and select Appearance 

 

 
 

     

 Choose the Text colour and Background colour 
 

 
 

Once the level colouring is set, it will need to be turned on in the Bar chart. 
 
To turn the colour on: 
 

 On the Format tab, click the Format Bar Chart command 
 

 

 DO NOT 
delete 
summary/expanded 
tasks as this will also 
delete all of the 
contents from your 
project.  
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Using the project view to navigate your project 
The structure of our project is clearly displayed in the Project View. 

 

 Click on the „+‟ sign to open the contents of heading. Programme is usually 
the top level. 

 Select any of the summary groups to display only that section of work on the 
Bar Chart 

 

 

Code libraries 
Code Libraries allow us to colour-code tasks so that their appearance 
represents something relevant.  A project can contain many code libraries, 
which can be hierarchically based. 
 
The codes are created in the Library Explorer. 
 

Creating code libraries 
For this example we will create a Code Library for Contractors used in the 
project. 
On the View tab click the Library Explorer command.   

 
 

 In the left window of Library Explorer, click on the Code Library folder. 
 
 

  
 

 In the right window, on a blank part of the screen, right click and select New 
Code Library.  
 

 
 
 
 
 
 
 
 
 

 The 
Construction Template 
will already contain a 
selection of Code 
Library folders. These 
can be edited or you 
can add your own to the 
list.  
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 Give it a name 
 

 

 In the right window, double click on the 
Contractors folder. 

 Right click in the right hand pane and choose New Code Library Entry. 

 In the Untitled box type in ‘Forest Landscaping’ to represent our first 
contractor. 

 Click under Foreground Fill, Background Fill and Pattern to select colours 
and patterns to identify this contractor. 

 
 

 
 

 Right click under Forest Landscaping to create a new code entry for Janson‟s 
Timber. 

 Repeat the process until all contractors are added. The other contractors are; 
Acme Building, Goldstone Utilities and Smarts Decorators  
 

To return to the project: 
 

 Click on the Bar Chart View Tab above the library explorer 
 

 
 

Allocating codes 
Now that the Code Libraries have been created we can apply these to tasks 
within the project. To do this we will use the Project View 

 

 To expand the list of Code Libraries in the 
Project View, click the + to the left of Code 
Libraries. 

 To expand the list of Contractors codes, 
click the + to the left of Contractors. 

 
 
 
 
 

Single Task allocation 
To allocate Acme Building to Dig Footings: 

 

 Place the cursor over the Acme Building code entry in the Project View 

 Press the left mouse button and drag until the cursor is over the Dig Footings 
task, then release.  

 

 

 If required the 
colours selected for your 
code library entries can 
be made visible in the 
project view. Go to Tools 
– Options – View & tick 
box at the bottom to 
‘Show code library 
appearance. 
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You will get the following message. Click Yes to apply the new Code Library 

colour 
 

 
 

Multiple task allocation 
To allocate Goldstone Utilities to both plumbing tasks: 

 

 Select First Fix and Second Fix (of plumbing) by holding down CTRL and 
clicking them 

 Place the cursor over the Goldstone Utilities code entry in the Project View. 

 Press the left mouse button and drag the cursor to one of the Plumbing tasks 
then let go of the mouse. 

 

 
 

 Click away to deselect and the bars will change colour. 
 

Switching the display between code library folders 
Powerproject will only allow you to display one Code Library at a time on your 
tasks.  To switch between folders:  

 

 In the Project View, Right Click on the Code 
Library Folder you wish to  display and select 
Display Library 

 The red tick indicates the code library 
currently on display.  

 
To remove the display of Code Libraries: 
 

 Right Click on the Folder that is on display 
(shows a red tick)  

 
Select Display Library to remove the display of this library. No code libraries 
are now selected to be on display.   
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Simple filters 
Now that the project is coded, filters can be used to show only the tasks with a 
certain code.  
 
To run a filter on the Forest Landscaping contractor code: 

 

 On View tab click on the Filter  command. Under the Codes category, 
select Which Code (Asks for codes) 

 Click on the + against Contractors and tick the box next to Forest 
Landscaping. 

 

  
 

 Click on Finish and run the filter. 

 To stop a filter running, click on the Filter command and select No Filter. 

Editing the view 
The „view‟ of your project is made up of 3 areas. Changes can be made to the 
appearance of each of these areas independently. 
 

 
 

The Date Zone 
The Date Zone is the area where date information relevant to the project is 
displayed. By default the Date Zone shows 4 rulers (Date lines) running across 
the top of the project, these are the Year, Month, Week Start and Project Week 
Numbers (elapsed weeks). 
 

Spreadsheet Bar Chart 

Date Zone 
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Adjusting the scale of the Date Zone 
You can adjust the scale of the project on screen by adjusting the date zone 
scale, 

 
 
 

 Place the mouse in the Date Zone area on any of the red lines (tick marks) 

 Left click and drag the mouse either left or right.  
 

Week Numbering 
Week 1 in the Date Zone will default to the project's start date when the project 
was first created. This is displayed in the „elapsed week‟ line.   
 
To align week 1 to another date: 

 

 Place your cursor anywhere in the Date Zone area and right click. 

 Select Properties. 

 Select the Dates/Scales tab. 
 

 
 

 Against ‘Date Zero’ use the date picker from the drop down arrow to choose 
your new week 1  

 Click Close 
 

Adding/editing rulers on the Date Zone 
The Date Zone can contain up to 10 rulers of date information across the top. 
To control the information that is displayed: 

 

 Place the cursor anywhere in the Date Zone area and right click. 

 Select Properties from the list. 
 
The General tab controls the folding Calendar & the date ruler on display. 
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 To add a fifth ruler, click once on an unused ruler and select from the drop 
down list. 

 To remove any of the rulers first select and then choose unused from the list. 

 Click on Apply to see the changes on your project.  
  

Grid Lines  
The construction template supplied with Asta Powerproject comes with some 
grid lines, Year, Month, Week and Day. 
 
A vertical grid line that occurs at a variable date specified by you can also be 
added to the project. E.g. a line that shows at „Today‟s Date‟ or the „End of 
week‟. 
 

 Select the Grids tab from the Date Zone Properties dialogue 

 Click Add to add a new grid line.  

 Enter a new Name 

 Left click in the Time Unit column 
and change Elapsed Week to 
Variable date 

 Click on the thin black line and 
change the line Style to how you 
want your line to look 

 Then left click in the empty space where the Variable date will be and a date 
picker will appear, choose your date or click on „Click to select variable date‟ 

 Press Close 
 

Shading 
Asta Powerproject can also put shading behind the tasks within the project, it 
has no affect on the project but it can be used to show certain information i.e. 
bad weather, school term times etc.  

 

  Select the Shading tab from the Date Zone Properties dialogue 
 

 Enter the Start and End dates for the 
shading or a „Variable Date‟ (see 
grids) from the list and then choose 
a colour. 

 Click Close to close the properties 
dialog. This will also „Apply‟ 
changes. 

 

Slicing the Date Zone 
The Date Zone can also be „split‟ into two or even three different scale zones, so 
that all three areas can be scaled separately. 

 

 Place the mouse in the Date Zone, over the area you want the new section to 
begin. 

 Right click with the mouse. 

 Select Start New Scale Zone.   
 
 
 

A faint grey line will appear at the point of clicking, dragging any of  
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the red lines either side of the grey line will adjust the scale ONLY in that area. 
 

 
 
 
 
 
 
To remove a scale zone: 

 

 Right click on the right hand side of the line you wish to remove 

 The line will be removed and the scale will revert to how it currently looks on 
the left hand side. 

 

Hiding non-working time 
 

 Select from the options to ensure that non working 
time is not displayed in your folding Calendar. 

 
 
 

 

The Bar Chart 
There are many Bar Chart attributes that you can switch on and off to tailor the 
chart display exactly to your needs. For example, you might prefer to turn float 
off and links off and even the Critical Path.  
 
The majority of changes to formatting can be found in the Format tab. 
 
The most popular formatting changes can be made using the Show/Hide 
toggles, which turn on or off various items of the display. 
 

 
 

There are also a number of keyboard short cuts which can be used: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
For further formatting options it may be necessary to go to the Format Bar 
Chart command to bring up the full list of formatting options. 
 

 

   Zone 1  |                         Zone 2                                         | Zone 3 
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 On the Format tab, click on Format Bar Chart command  
 
 

 Schedule tab 
 
 

 Un-tick Free float, Total float and Critical 
path to hide these on the bar chart 

 
 
 

 Links tab 
 

 Un-tick the link types shown under the 
„Show‟ section to hide these links on the 
bar chart 
 
 
 

General tab 
 

 Un-tick Constraint flags to hid these on 
the bar chart 

 
 

Display notes on tasks 
Notes can be added to task properties and displayed via a pop up window on 
the Bar Chart.  

 
To add notes to a task: 
 

 Right click on the task.  

 Select Properties. 

 On the Task Tab select Status from 
the list on the left hand side. 

 Notes can be written into the space.  
 

If the tick box on the task tab of the 
Format Bar Chart dialog is checked, an 
indicator will be visible in the top right corner of the task. Place cursor on the 
task and the notes are displayed in a pop up window. 

 

 
 

The Spreadsheet 
The Spreadsheet can be customised to display whatever project information you 
choose.  Columns contain Fields which read data from your project, End date, 
Start date, Percent Complete and can be added, edited and deleted.  
 
The Spreadsheet can be saved as a table so that it can be applied to other Bar 
Chart views. For example, you might have one table for entering new tasks and 
another for assigning progress.  

  These notes 
can also be displayed 
in a Spredsheet 
column using the 
Identification token for 
Notes.  

 The Undo button 
does not affect these 
changes to the 
appearance of the 
project. 
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To add new columns 
 

 Right click on an existing column heading and select Add Column 
 

 
 
 

 Choose a Field category (e.g. Identification) and then choose a field (e.g. 
Notes) 

 In the Table Definition Properties pop up that ensues you will be able to 
change the settings for that column. 

 

 
 

 

 Click Close once you have made your changes. 
 

To move the position of columns 
 

 Place the cursor at the top of a column heading so that the 
select/move cursor is displayed. 

 
 

 Left click & drag column to desired position. 
 

Saving the Spreadsheet 
You can save the columns that have been created as a table, which will allow 
you to switch between the different tables as required. 

 

 In the View tab, click the Table command 

 Select Save As 

 Give your table a new name 

When
cursor is 
displayed, left 
click and drag to 
move column  
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 Choose a Category for the new table to be saved in 

 To switch between different tables, in the View tab, click the Table command 
and select from the list of saved tables 

 

 Table definition 
The Table Definition can also be used to create new tables and is useful for 
setting more specific attributes to produce more advanced tables e.g. changing 
a column title, referencing a token to a baseline rather than to the live project. 

 

 Right click on a column heading and select Table Definition 
 

 
 

 In Column title change the title of your column 

 Click Close 

Annotations 
Annotations are text and graphics that you can include on bar charts to enhance 
the presentation of your project. 
 

Creating text annotations 

 On the Home or Format tab, click the Text Annotation command    

 Take the cursor onto the bar chart. Your cursor will be a letter „T‟. 

 Left click and drag the mouse downwards & to the right to draw a box. 
 

 
 

 Type the text that you want in the text box. 

 The text colour, font, style and size can all be adjusted using the Font section 
of the Home tab. 

 Click away to deselect the box. 
 

Attaching annotations to tasks 
Text annotations can be created to refer to specific tasks in your project. In this 
case the text box can be attached to the task so that it stays with it should it 
move in your project 
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 Click on the annotation you wish to move 

 Hold the left mouse button down, and drag the annotation toward the task you 
wish to attach it to 
 

 
 

 The cursor will change shape to indicate how the text box will attach to the 
task 
 

Inserting fields into text annotations 
You may type project or task specific information into text annotations   e.g. end 
dates or percent complete.   However when the task is updated the annotation 
will not. Asta Powerproject can use „Fields‟, which update according to current 
project data. 

 

 Double click the text annotation so that the cursor is inside ready to type.  
 

 Right click to display a list of available „Fields‟. 

 Select a field as required e.g. select Date – 
Finish. 

 Click OK at the pop up box. 

 When deselected, the annotation will display 
the end date of the task. If the task should 
change the annotation will also be updated.  

 
 
 

Formatting the text annotation 
The properties of the text box can be adjusted to control how it looks on your 
project e.g. whether there is a border, set the text into the background of the 
project or even make the task annotation appear only against specific tasks in 
our project. 

 

 Left click once on the annotation to select it. 

 Right click and select Properties. 
 

 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 

Set a 
background 
colour and to 
display text in a 
„box‟ 

Set to display 
annotations „in 
front‟ or „behind‟ 
tasks on your 
chart 

Tick here to 
make the 
annotation 
appear against 
every task or 
select a filter to 
control which 
tasks it appears 
on.  
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Using progress 

Once the project is underway, you should record its progress at regular 
intervals.  Recording progress ensures that your project is kept up to date and 
lets you see if work is progressing as planned or if delays are creeping in.  It 
also ensures that you know how much work remains to be done to complete the 
project and will also give you a projected project end date. 
 

Displaying progress in the bar chart 
To view the progress drop line and shading on the tasks within the Bar Chart: 
 

 On the Format tab, select Format Bar Chart 

 Select the Progress tab 
 

 
 

 

 Put a tick in the Lines On tick box 

 If you tick the Progress entry line only option, the software will automatically 
show the drop line of the selected report date. 

 If you want a specific progress drop line to show, select the progress period 
by placing a tick against that progress period. 

 Select Coloured from the shading menu then Close. 
 
The line will begin from your report date and „jag‟ around the uncompleted tasks 
and baselines 
 

 
 

You may also be able to choose this option by: 
 

 On the Format tab, select the  command 
 

Entering Progress 
There are numerous ways within Asta Powerproject to enter progress onto 
your tasks. The easiest way is to use the spreadsheet to enter the data. 
 

N.B The % Complete 
column here is 
independent of the 
duration of the task. 
It is the percentage of a 
tasks work that has been 
completed & will remain 
the same regardless of 
whether the task duration 
increases or decreases 
(e.g If you set the 
progress to 20% and 
then increase the task 
the percentage will 
remain the same). The 
Field used is Overall 
Percent Complete. 
 
If you want to record the 
percentage according to 
the duration completed 
(e.g if you mark the 
progress as 20% and 
then increase the task 
the percent complete 
reduces) then you would 
need to choose the 
Percent Complete Field 
(see the section entitled 
The Spreadsheet for 
how to create this 
column using Fields) 
completed (Overall 
Percent Complete) 
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To show the progress specific columns: 
 

 On the View tab, select the Table Command 

 Under the Progress category, select Progress – no baseline. If this table is 
not present, add the following columns: 

 
o Name 
o Actual Start 
o Actual Finish 
o Overall Percent Complete (rename to Percent Complete) 
o Planned Percent Complete 
o Slip  

 

 Any progress entered into the Percent Complete column will be added to the 
task, giving the task a scored through appearance. 

 

 
 
 

Rescheduling with Progress 
To see the effects of the progress we will ask Asta Powerproject to straighten 
the progress line and move any uncompleted tasks to the right of the report 
date. If you have not baselined, then you need to be aware of the original end 
date of the project as straightening the line may affect the end date of the 
project. (The Undo option is available to rectify this)  
 

 On the Home tab, click the Reschedule Command  

 In the Reschedule Progress Period Warning pop up, the Straighten 
progress entry period should be set to Progress Entry Period. If you do 
not want to straighten the line, select  None.  
 

 
 

 
The progress line will straighten and the uncompleted section of the project will 
move to the right of the report date. 
 
 Before     After 
     
                          
 

 
 
 
 
 
 

N.B If the above pop up 
doesn‟t appear this will 
be because the “Do not 
warn again” box has 
been ticked at some 
point. If this is the case 
you will need to carry 
out the following. 
 
In the file menu, select 
options then the 
general tab. Choose Do 
not show me again 
prompts and click reset 
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Once the line has straightened you can change the view to show the straight 
line progress as a jagged version; see the next section entitled ‘Straight line to 
Jagged line display’. 

 

Setting up the project to Print  
As a general rule what you display on the screen is what will be printed.   
 
Therefore, select the „View‟ of your choice or manually change any formatting, 
tables etc to customise the display to what you wish to print. 
 
The scale of the project can be adjusted for you to allow printing to a certain 
number of pages. 
 

Editing Details for display on your Borders  
When you print an Asta Powerproject file it is printed with a border around the 
project. The border file enables you to display relevant project & company 
information along with your project data.  
 
Some of this information, like the Project Name, Who the project is by & who it 
is for has already been completed and can be accessed: 
 

 Select the File tab, selecting Advanced Properties 
 

 
 

All further information, such as revision dates, programme numbers etc can be 
found: 
 

 Select the File tab 

 Click the Print command 

 Choose Full Preview  

 Click on the output fields tab.  
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Printing the Project 
As a general rule what you display on the screen is what will be printed. 
Therefore select the „View‟ of your choice or manually change any formatting, 
tables etc to customise the display to what you wish to print 

 

 Select the File tab and click the Print command or  

 Click the Print button  on the Quick Access toolbar  
 

Output Tab 
The output tab control where the print out is going to and what file type is going 
to be created if applicable. The main output options are: 
  

 Printer – Tick Printer and choose your printer from the drop down list; from 
the properties button decide your printer orientation and size (standard printer 
usage) Press the Print button to activate Print 

 Clipboard – Tick clipboard to have your print preview copied to the clipboard. 
You can then open Word, Excel etc right click on the page and select paste, 
to paste your print preview into the document. Press the Print button to 
activate the copy to clipboard. 

 

 Picture File – Tick Picture file to have your print converted into a JPEG 
picture file, which can be inserted into Word, Excel, PowerPoint etc. Use the 
Browse button to choose where to save the new file and what filename to 
give it.  Press the Print button to activate the file creation 

 PDF – You can create a PDF but you must have a PDF creator amongst your 
printer drivers. (Consult your IT to have one installed) 

 
The Print Range decides which pages of the project document you wish to print 
this time: 

 

 All – Prints all pages 

 Selection – Prints only what you have selected in Powerproject  

 Pages – Prints only the pages you specify in the available field 
 

Details Tab  
In the Details gives the options for your border file and lets you limit the dates of 
the project you wish to print. 
 
To choose a border file: 
  

 Click on Browse 
 

 
 

 The border files contained within the default border file will now be displayed. 
You can select a file from the list, or browse to another folder if you have your 
own border saved elsewhere. 

 Clipboard is when 
the system takes a ‘snap 
shot’ of your project as if it 
were to print on paper. But 
rather than putting it on 
paper, it stores it in the 
computers memory so you 
can go into any other 
application (i.e. Word) and 
do Edit – Paste. It will then 
appear as a picture object 
in that application (in a 
read-only format) 

 Picture File is  
similar to the clipboard 
option, but instead of 
storing it in the computers 
memory it writes it as a 
picture file (JPEG 
extension) so that you can 
either email it to someone 
or to insert it as a picture 
object in another 
application (i.e. Word) 
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 The filenames of our border files contain a name (i.e. CHT) and page size 
(i.e. A3) and the orientation of the paper (i.e. L for landscape or P for portrait) 

 A good default border to use would be CHTA4L A thumbnail will appear on 
the right hand side 

 Click Open 
 

Borders are separate files on your computer or network and do not form part of 
your Powerproject file. This may mean that if you send your project elsewhere to 
be viewed or printed, such as via email, the border file may not be available to 
the recipient.  
 
To avoid this, you are able to embed the border file which will add a 
compressed copy of the border file to the Powerproject file, meaning if it were to 
be sent the border file would be included. 
 
To embed the border file: 

 

 Click on the Embed button 
 

 
 
 

 Choose a name for your embedded border (N.B it doesn‟t have to be the 
same as the Border file). 

 Click OK 

 The Embedded border shows in the Border file list and the Embed button now 
displays as Delete 

 Delete is active so that if you no longer need the embedded border it can be 
deleted from the .pp file. (N.B this does not delete the main border file) 
 

Once a border file has been selected, you will need to make sure the chosen 
printer is set up to match your selected output in terms of paper size and 
orientation. 
 

 Select Printer Page size and Orientation ensuring they match the border 
settings. The printer settings are the overriding factor. 

 

 
 

In the date range selection, you are able to select specific dates within the 
project that you wish to print: 
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 From the two drop down cells, choose a start date for the data you are 
printing and an end date to slice that period for printing 

 
Once you have chosen your settings, sizes and selections in the print dialogue 
box you can save all these ticks and clicks as a Print Profile.  Next time you 
then want to print, you go straight to the print profile and choose the profile that 
you want.  All the selections will be remembered. 

 

 
 

 With all selections made click on Save As 

 Give your new profile a name, click on OK 

 This can now be chosen each time you print 
  

Scaling Tab 
The scaling tab is used to control the size of your print out. It can be set 
manually, by selecting the actual print size of a time unit (i.e. 1 Week to a 
centimetre) or by selecting the number of pages you would wish to have. 

 
The View Scales options allow you to control the size manually: 
 

 Override horizontal (date zone) scale – Allows you to control the scaling of 
the date zone (size of a week etc)  Automatically set by default 

 Override vertical (Chart) scale – Allows you to control the scaling of each 
bar line, Allocation and Baseline height.  This is controlled by the settings in 
Format Bar Chart, Vertical Scale but does not set them in the programme. 

 
The Scaling Type details how the border file will be used on a multi page print 
out. 

 

 Fit border around output – If printing to more than one page, this setting 
allows you to apply the border around all of the pages 

 One border per page – If printing to more than one page, applies your 
chosen border to each page printed  

 

 
 

One border per page Fit border around output 
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The Horizontal & Vertical Pagination options allow Asta Powerproject to 
adjust the size of the print out to fit to a chosen number of pages. 

 

 True size – Prints your plan at the exact size set in the date zone or 
spreadsheet, so may end up printing across a number of pages. 

 
o Horizontal scaling – With true size selected this will increase or 

decrease your print out by the number selected e.g. 1.5 would print at 1.5 
times it‟s normal size 

o Expand to fill space – Expands the chart to the edge of the border 
o Vertical scaling – Increases your vertical scale by the number entered.  

E.g. 2 would increase your vertical scale by twice the height 
o Use Defined page breaks – Prints a page dictated to by the position of a 

page break.  A page break is created in the bar chart by right clicking in 
the bar chart where you want the page break to happen and selecting 
Page Break 

 

 Fit lines per page – Gives you control of how many lines you would want 
printed on each page 
 

 Fit to at most -  Will fit it to the pages you specify 1x1, 2x2 but if you choose 
a size which is beyond a reasonable printout e.g. 5x5 pages for a 10 line 
programme it will keep it to a size which it regards as a best fit 
 

 Try to fit to exactly – Will fit exactly to the pages requested whether it would 
look reasonable or not 

 

Appearance tab.  
The appearance tab allows you to add or remove certain elements of the 
printout, such as legends, shading and hidden columns. A small selection is 
shown below 
 
 

 
 

Legends – this 
shows a key at the bottom of the print out for 
any of the items ticked 

 
 
 
 
 
 

Bar Chart – „Show 
date shading‟ will either show or hide shading 
used on a plan 

 
 
 
 
 

Spreadsheet 
– „Tick Visible columns‟ only to only print the 
columns you can see on the screen  
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Date zone – „Display at foot‟ will show the date zone at the bottom of the page 
as well as the top 

 
On the right of the dialogue box: 
 
 
 

 Legends – You can change the font of the legends which display at the base 
of the print out or just use the fonts from the spreadsheet 

 Spreadsheet – If a font is difficult to read you can use these options to 
change the size of the font in the spreadsheet to make it easier to read. 

 

 Off – No scaling 

 Automatic – uses default scaling 

 Use – Increases the scale of the font by a defined amount  
 

Preview 
We would always recommend you click the Preview button to check the output 
before printing.  

 

 To return to the properties dialog and make any changes, click the icon 

to the right of the print button. 

 Finally, click the Print Button to print your project. 
 

Templates 
Templates are used to make creating a new project as quick as possible, as the 
template can contain filters, code libraries, tables and many more items that you 
may use. 
 
To create a template, it is best to base it on one that already exists (e.g. 
Construction Template) as this should already contain some items that may 
prove useful to you. 

 
Once this project has opened on the screen you can now create everything you 
want in the template (e.g. Filters, Code libraries, etc)  
 
You can even include titles and tasks within the Bar Chart. This could mean that 
for the first few lines of the project, you type in the most common titles (and 
include tasks is you wish) as it is quicker to delete something than to create it. 
 
Once everything has been created, to save this project as a template: 

 

 Go to the File menu, select Save As 
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 The Projects folder & contents are displayed. Go up a level by clicking once 
on the yellow folder just to the right of the folder window 

 Inside this folder double click on templates  

 The templates folder & contents will be displayed. At the bottom in the File 
Name you can rename your project template if you want to. Then click on 
Save 
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Appendix I 

 

User Defined Fields 

Within Asta Powerproject can add your own “user fields” to tables in the 
database.  For example you might want to add fields to show delay notes, 
progress comments or if a task has been approved. 
 

Creating user fields for your projects 

 First the project must be saved. The User Field Manager will not be 
available if there is any unsaved information. 

 Select Project tab and click the User Field Manager command. 
 

 
 

 Click on the drop down arrow and select Bar from the Object Type, then click 
Add. 

 Select the type of field that you want to create: 
 

 String – a text field, e.g. for a name or comment field.  
 

 Integer – a field for whole numbers. 
 

 Float – a field for decimal numbers. 
 

 Boolean – a True/False field, e.g. for an option that can be on 
or off. Boolean fields might be shown as check boxes or drop-
down controls providing Yes/No or True/False options. 

 

 Date – a date/time field, e.g. to record the date or time. 
 

 URL – A hyperlink field 
 

 

 

 The field name 
doesn’t like spaces, and so if 
you want a space (e.g. QA 
Approved) then use an 
underscore (_) between the 
words. When the column is 
added into the table, use table 
definition to edit out the ‘_’ in 
the title 
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As String is selected by default, enter the name “Comments” in the User Field 
Name box.  

 

 Click OK 

 Click Close  

 The user field is now available on the properties dialog of the particular task 
it is to be used on or can be created as an extra column under the Token 
Category of User Fields 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The following sections contain: 
 

Instructions on how to use the Asta Powerproject Help system. 
 

A glossary of technical terms used. 
 

Example exercises 
 

 When you select 
Apply or Close, all views in 
the active project are 
closed so that the database 
can be updated. Use the 
View menu to re select your 
chosen view 
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Appendix II 
Asta Powerproject’s online Help provides all the information you need to use 
Asta Powerproject to the full, presented in an easily-accessible format. 
The programs that are associated with Asta Powerproject, for example Asta 
Powerdraw and ServerAdmin, are also supported by comprehensive online 
Help. This leaflet describes how to access the online Help files and gives tips on 
how to use them to find the information you are looking for. 

 

Accessing the Online Help 

 

General Help 
 

 Press F1 from any screen in Asta Powerproject. 
Or 

 Click the  command on any screen. 
 

 
 

 
 

Searching for Help Topics 
Asta Powerproject provides three methods to search for help, Contents, Index 
and Search. 

  
 
 
 
 
 
 
 
 
 

 

Using Content  

 
 

 Most useful when you know generally what to do, and you are searching for 
specific detail. 

 Results are displayed in a logical order relating to the order you would 
normally use Asta Powerproject. 

Navigation Pane 
The left hand pane of 
the online Help 
window, known as the 
Navigation Pane is 
divided into a number 
of tabs – Contents, 
Index and Search – 
which you can use to 
locate the information 
you need 

Results Pane 
Displays the Help 
Information 

Contents Tab 
Displays all help topics in 
hierarchy of books & 
pages. Search by 
browsing through topics. 

Index tab: 
Lists Terms & Phrases 
alphabetically and these are linked 
to topics within Help 
Search example: Entering TA in the 
search field will return results Table, 
Tabular, Tagging and Tasks 
 

Search tab 
Keyword search returns 
all matches from 
anywhere within help 
contents 
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Using Index Help 

 These are the most specific of the searches.  

 They are most useful when you are confident that you are using the correct 
terminology.  

 Results are displayed as a list of headings and sub-headings. 

 Each sub-heading is a topic. 
 
 

 
 

Using Search Help 

 The most general of the search methods. 

 Most useful when you have no idea where to start search or when 
exploring new areas of Asta Powerproject. 

 
 

 

Finding Information Using Related Topics Links 
 

 „Related Topics‟ links are a very useful way of finding out about something in 
more detail.  

 Most topics in the online Help have a list of related topics at the end, which 
provide you with information that is connected to the current topic in some 
way.  

 

Frequently Asked Questions 
 

 Frequently Asked Questions (FAQ‟s) can be accessed from the „Quick links‟ 
section on the Welcome screen of the help file. 

  The FAQ section is divided up into subject categories. 

 The categories contain the most commonly sought information within that 
subject. 

 Enter Keyword 

 Select Topic 

 Click Display 

Topic content covered 
here 

Enter search term 

List Topic to 
refresh results list 

Display to refresh 
topic item 

Topic content 
displayed here 
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 They can also be found on our website (www.astadev.com) under Technical 
Support – FAQs 

 

New Features 
The What’s New? feature is available to existing users who have upgraded 
their Asta Powerproject program. 

 

 
 

Using the Navigation Bar 

 The navigation bar is most useful when browsing around help. 

 Back button takes you quickly to previously viewed pages 

 Forward button is only active after the back button has been used. 

 Asta Development PLC Home page is www.astadev.com 

Printing Help Topics 
Your print options will depend on the version of Microsoft Internet Explorer you 
have installed, and the printers that are available to you. 

 

 Display the topic you want to print in the Topic pane. 

 Click Print in the Help toolbar. 

 You may see a dialog offering you the option to print the selected topic, or the 
selected topic and all its subtopics. Choose to print the selected topic only.  

 Complete the Print Dialogue box. 
 

Getting More Information 
You can find more information on how to use Asta Powerproject Help within the 
Help itself. For example, you can find detailed information on how to navigate 
around topics, how to set options that change the way the Help is displayed and 
how to use advanced searching techniques to find the information you need. 
For more information on getting Help, refer to the „Using Help‟ topic in the online  

 
 
 
 
 

  

Display 
Options 

Asta Home 
Page 

Go to previous 
item 

Show/Hide 
Search Pane 

Go to 
next item 

Print current 
topic  

 

http://www.astadev.com/
http://www.astadev.com/
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Help Glossary 

Allocation –  
This is the name given to any item, for example Permanent or Consumable resources that can be 
assigned to a task from a library. The allocation can be displayed on the Bar Chart underneath the task.  

Bar –  
Horizontal area on the spread sheet and Bar Chart containing information about a task.  

Bar Chart – 
The area of the screen where tasks can be viewed graphically. 

Baseline – 
A complete copy of the project recorded at a stage in time. Asta Powerproject can record and display 
multiple baselines allowing for: tracking of major changes; production of what-if scenarios; comparison of 
information (e.g. budget cost to actual cost) 

Border File – 
A print function which contains information to be included in you printouts, including graphics such as 
company logo, project information such as the project title and relevant dates.  

Buffer – 
A Task that is used to collect float and protect the Critical Path through the project. It achieves this by 
having its duration dynamic which increases or decreases in response to project changes. 

Code (Colour) –  
A facility to allow the assignment of colours to tasks to represent information about the task. 

Code Library – 
This is the library (or folder) that contains Codes, allowing you to have multiple „categories‟ of codes 

Constraint (Flags) – 
These are used to enforce dates when a Task can happen (stopping a task starting before a certain date, 
or stopping a task finishing after a certain date). Using Constraint Flags within the project can have a 
major affect on your Critical Path 

Consumable Resource –  
This is a resource that if it is used today, it is not there tomorrow (e.g. bricks, mortar, and piping) 

Control Key (CTRL) –  
A key on the key board normally found at the bottom left (and one on the right) used throughout windows 
applications for either commands (e.g. CTRL + S for saving) or for selective highlighting. (To highlight 
everything that is clicked upon whilst the key is held down) 

Cost Centre –  
These are items that are used to assign costs to Tasks in the project (either directly – fix cost, or indirectly 
– via Cost and Income Rates). Either one can be used through the project, or multiple ones to show 
different categories of costs incurred (e.g. Labour, materials, plant) 
They can also be used for money coming in to the project (Income) rather than money leaving the project. 

Cost and Income Rates – 
These are items that can be assigned to Permanent Resources to show how much they cost per „time 
unit‟. It could be a daily cost or even an hourly rate. These act as the „middle man‟ between Cost Centres 
and Permanent Resources allowing Cost Centres to be used indirectly. 

Critical Path – 
This is shown as a red outline on Task and all Links showing red, the critical path means that this is the 
most important route through the project. If any of the items on the critical path are changed in anyway 
(durations or positions of) then the end date of the project will change, becoming earlier, or later 

Date Zero –  
Normally at the start of the project, but can be moved without affecting the project. Date Zero is the point 
where week -1 meets week 1 (so allowing you to make your project „start‟ in week -10) 
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Date Zone –  
This is the area above your project that contains rulers of information (e.g. week numbers, week start). 

Exceptions – 
These are time periods that are different to the usual work week. E.g. Holidays, overtime etc. 

Expanded –  
This type of task is very similar with Summary tasks, in that it is used to group together Tasks within the 
project, but rather than have them on screen with itself like the Summary task, the content is actually held 
off chart in its own chart (or Sub Chart as it is commonly known) 

Filter – 
This is a tool that will leave on screen only those items that meet a particular criteria, for example all the 
items that a particular contractor is doing (Code based filtering) or you want to see everything but only 
during a 6 week period (time based filtering) even to show only those items that have been completed 
(Progress based filtering) 

Float –  
This appears on items that are not on the Critical Path. Float is the amount of time a Task may be delayed 
or extended before the item rejoins the critical path and pushes out the end date of the project. See Total 
Float and Free Float for more information 

Free Float – 
This is one of the two types of Float; Free float means that if the task is extended or delayed in anyway 
during its period of float only this item is affected, nothing else will move. 

Lag (Links) –  
Waiting time that is shown as the horizontal part on a Link (e.g. Concrete curing time, paint drying time or 
just delivery times). 

Library Explorer –  
This is another main area of the software, It is inside of here that certain items are created (Cost Centres, 
Calendars, Codes, Permanent Resources to name but a few) But also certain settings can be changes in 
here as well ( the exception colours, link colours, working in pounds or Euros)  

Link – 
This is an arrow going between two items, representing the logical path through the project. Where one 
Task can start before another one. If shown in red then the link is Critical. 

Macro –  
A macro is a piece of code (software) that has been written to remove long, repetitive or complicated 
procedures by the user.  

Mid-link – 
The software supports 4 major types of Links and a mid-link is one of those four with some setting to it so 
it allows it to be drawn almost anywhere along the task rather than from (or to) the start or end of the Task 

Milestones –  
Milestones are points in time; they have no duration of their own (0 days) and are used to represent key 
events within projects. (E.g. Handover) 

Overlapping Links –  
See Mid-Link 

Permanent Resource –  
This is a resource that if it is used today, it is there tomorrow (e.g. man power, machinery) 

Progress (Period) – 

Progress is the method used to mark up the project so it is easy to know whether the project is in front or 
behind. A progress period is the reporting date, shown as a line going down the screen, and it will bend to 
the left to show items behind time and bend to the right to show items ahead of time.  
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Project View –  
This white window that opens on the left hand side of the screen is used to navigate around the project, or 
to assign items into the project like Code Libraries, Cost Centres, Permanent Resources, Consumable 
Resources and Calendars. 

Shift Key (or a bold arrow pointing up) -  
A key on either side of the keyboard, used for creating capital letters, to pick up any of the top row of 
symbols on the numerical keys and others. Also used to highlight a range of items, (left click on one item, 
then hold down shift and select another item. Everything in between becomes highlighted.) Also used for 
creating Lag links. 

Snapping Unit Box – 
This is the window on the toolbar at the top of the screen, normally with the word days written in it. This 
window controls many areas of the software. It is mainly used to control the units Tasks are drawn in 
when the mouse is dragged across the Bar Chart. But it is also the default duration of Tasks when typing 
in the Spreadsheet, so if a duration was entered without the time unit after it (1 instead of 1d) then the 
resulting Task would be in the duration defined by the Snapping Unit Box 

Sort –  
Unlike a filter that temporarily removes items off the screen, a sort will leave all Tasks on screen, but will 
reorder them according to criteria that have been set. For example, rather than the program showing the 
Tasks in time order (earliest task first as most programs are created) the project could be told to group 
together all the Tasks according to the Code that has been assigned to it  

Spredsheet – 
This is the yellow and white stripped table down the left hand side of the screen (assuming the Project 
View is closed) the Spreadsheet is made up of different columns and these columns can be removed, 
added or even moved around. The software supports a large number of these columns              

Summary – 
This is an item that groups together Tasks on screen under its own task. Items are grouped because they 
share certain information, for example, summaries could be used to group together all the Tasks on 
different floors. A Summary could also be used to show different phases or even stages within a project. 
Summaries can be placed inside of each other allowing a project structure or hierarchy to be created 
(Three different buildings, broken up into 4 different floors – so 3 main summaries each containing 4 more 
summaries inside of them)      

Task –  
The activities or „blocks‟ that appear within a Bar on the Bar Chart. 

Template – 
A template is a file that is used when creating a project from new. This particular file will already contain 
items needed in the project. So a template could already have Calendars, Permanent Resources, Cost 
Centres, Code Libraries it could even have titles in the Spreadsheet and Tasks in the Bar Chart.       

Total Float –  
This is one of the two types of Float. Total float means that if the task is extended or delayed in anyway 
during its period of float, then all items directly after it (those containing Float) will also be affected as well. 

UDF –  
User Defined Fields – the software already has a large range of columns that can be used in the 
Spreadsheet but every column has a use. UDF‟s are columns created by the user for whatever purpose, 
whether it is for recording delivery notes, delay notes or even to have a tick box to say whether or not a 
health and safety check has been done. 

View –   
A view is the method used for the software to remember screen settings. When saved the „view‟ will 
remember if the Project View is opened or closed, it will remember the current column configuration within 
the Spreadsheet. It will also remember the current settings of the Bar Chart, also the Date Zone and 
finally whether there are any Filters or Sorts running within the program. Putting all of this together a view 
is the ability to change all of these settings to a predefined set by only doing one click of the mouse. The 
software can have unlimited number of views saved. 
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Exercises 

 

Exercise 1 Shed Build 
 
You have decided that you need to buy and erect a new shed for your back garden. 
 
You know what tasks are involved and how long each task will take you. 
 

 The project will start next Monday  

 You will use the Construction Template,  

 Also you have given yourself a maximum of 7 weeks to complete the project, so it is likely that certain 
activities will have to be worked on at the same time. 

 The sixth weekend of the project will be available to work, so this period should be added to your 
calendar as Weekend Working (Morning and Afternoon)).   

 The first Friday you are going to take one day‟s holiday, again add this to your calendar. 
 
The title of the project will be Shed Build. 
 
Market Research  2 weeks 
Buy Shed   Milestone 
Delivery Period   10 days 
Dig Base   6 days 
Pour Concrete   2 days with a 1-day lag for curing 
Erect Sides   1 week 
Paint (2 tasks)   2 days for undercoat 
    2 days for topcoat 
Roof    3 days 
Window   1d 
Door    ½ day 
Lock    ½ day 
Final Checks   1 day 
Complete   Milestone 
 
 
 

Create a fully linked bar chart.  Each task must be linked and a reschedule is required to show the critical 
path. 
 
What is the end date of your project? 
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Exercise Two  
 
Open the Shed Build Project 
 
You are going to create a new project hierarchy. 
 
All current tasks will be put into the following summary tasks: 
 

 Phase 1 – Market Research, Buy Shed, Delivery Period, Dig Base 
 

 Phase 2 – Pour Concrete, Erect Sides, Paint, Roof 
 

 Phase 3 – All remaining tasks. 
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Exercise Three  
Open the Shed Build project. 
 
You have decided that rather than carry out the work yourself you are going to use local subcontractors. 
You will use a colour coding system to denote on each task which subcontractor is going to carry out the 
work 
 
Create a code library called Subcontractors with the following contractors as colour codes within. 
 

 Sheds R Us Ltd 

 Marley Ltd 

 Tristar PLC. 
 
Allocate the codes to the tasks of your choice 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



52  

 

 Asta Development plc Sep-12 

Exercise Four - Construction Project 
 

 Start a new project using the construction template 

 The File Location of your new project will be CONSTRUCTION  

 The start date will be next Monday. 

 Editing your default calendar 
 
Add the following exceptions to your default calendar: (5 day week, Xmas and Easter only) 
You will work overtime on the first 2 Saturdays of the project from 08:00 – 12:00. 
You will be taking a day‟s holiday on the 3

rd
 Friday of the project. 

 
 
Creating the Project 
 
Create the following tasks: 
 
Procurement sheet piles 15d 
Breakout concrete slab  3d 
Piling platform   2d 
Sheet piling   4d 
Base Reinforcement  5d 
Base Concrete   1d 
Roof Slab Falsework  4d 
Roof Slab Reinforcement 4d 
Roof Slab Concrete  1d 
Covers    1d 
Complete   Milestone 
 
Create a fully linked bar chart and then reschedule to show the critical path. 
 
Summarise the project by creating 3 summary tasks: 
 
Construction to include Procurement Sheet Piles to Sheet Piling 
Main Base  to include Base Reinforcement to the Base Concrete 
Roof Slab  to include Roof Slab Falsework to Covers 
 
 
Code Libraries 
 
You will use local subcontractors to do some of the work. Create a code library called SUB 
CONTRACTORS.  
 
Choose the name of 3 contractors and add them to the code library. Select an appearance for each. 
      
Allocate these to tasks in your project. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



  
 53 

 

 Asta Development plc Sep-12 

Exercise Five  
 
Open Shed Build project 
 
You are now 1 week into the project and would like to monitor the progress of the work carried out to date.  
 

 Go to View, Table, Progress and select Progress - No Baseline  
 
Marking Progress: 
 

 Change the default progress period to 1 week into the programme 

 Make Market Research 20% complete 
 
 
Reschedule the project to straighten to the default progress period and note the new end date of your 
project 
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